Set up Jabber Contact Photos for MRA

So my boss just configured Expressway for MRA (Mobile and Remote Access). Wow, was that a feat! Kudos to him. Maybe he’ll be a guest blogger for me at some point to explain how he did it. After all was said and done we found that after some research that getting photos into Jabber mobile is not as simple as a checkbox. You must configure the jabber XML file to pull the photos from a web server. Here’s how we did it.

First we watched two of Jaime Valencias awesome videos.

How to configure Jabber photos in a Web Server when using UDS

How to confiugre Jabber photos in a Web Server when using LDAP integration

Then we performed the following:

  1. Created a directory on one of our existing Windows 2012 R2 servers running IIS. New directory name C:\JabberPictures and copied a couple of pictures to it for testing.
  2. Created domain user jabberpics (in Jaime’s video he used Administrator).
  3. Created DNS record for the site. SNAGHTML8a5218
  4. In IIS, I created a new Web Site named Pictures.
  5. SNAGHTML1a1d5874
  6. Tested authentication settings. Success.
    • image
  7. Browsed to the URL of one of the pictures to see if it worked. Voila! So onto the next step of configuring CUCM and Expressway. SNAGHTMLed0800
  8. In Expressway Core, we added a new Editable rule under Configuraiton > Unified Communications > HTTP Allow List named Jabber Contact Photos. The syntax is very specific. It took several tries and a Meet with the Engineer session (at Cisco Live) to get it right. SNAGHTML1a1fd39cSNAGHTML1a201991
  9. We created a test jabber config XML file and added the highlighted string under the Directory section. And also changed the Directory Server Type from EDI to UDS if it’s not already UDS. SNAGHTML10c3ff1
  10. TFTP’d the XML file to our CUCM server. You can find some tips on the Jabber config file from Cisco Shizzle.
  11. Restarted the Cisco Tftp service under Feature Services since it’s a new file.
  12. For testing, we added configurationfile=jabber-config_test.xml to the Cisco Support Field of my CSF device.
  13. I performed  a Jabber Reset on my Jabber for Windows and also deleted the CSF folder located in %appdata%\Roaming\Cisco\Unified Communications\Jabber.
  14. I logged back into Jabber and noticed that all users photos were missing except for the few test photos I added to our web server. Wahoo! SNAGHTML11ee8ae